Instrumental sync issue

feature-request
todo:b015
lang:en

#1

It seems that voice track and instrumental track are not totally sync. There is some delay(less than 50ms) to voice or instrumental. Stopping and replaying temporarily solves the problem.

Yamine Renri is used.
Default settings.


Synthesizer V Editor Update (Build 015)
#2

I wonder if you’re loading a mp3 file as instrumental. The mp3 format itself isn’t designed for millisecond-grade precision so there’s nothing we can do about this. You may need to convert it to .wav or .flac or .ogg before use.


#3

Seems to be the problem. Should there be a buffer mechanic or something to fix it? Anyway, converting to .wav solves the issue. Thanks:smile:


#4

Maybe we can add a “convert to wav” option when loading mp3 files. I’m changing the tag to feature-request.


#5

A “convert to wav” option would surely help, or at least let people know the format thing.


#6

Or don’t let .mp3 or any other format with syncing issues be opened as an instrumental track. I just loaded up an mp3 to play around with build 014, and sometimes the words were in sync, sometimes not. I was very alarmed and began a bug post when this thread came up as similar. Whew. I feel better now. and will use a .wav file. For a minute there I thought all was lost!