Play button stops working after a while

After using the program for a while, or playing the song multiple times, the play button stops doing anything other than rotating sprites. Only way to fix this is to save and restart the program (which would be fine, if it weren’t for the parameter saving problem I’ve mentioned in another topic).

Do you mean that the playhead doesn’t move after pressing play button?
This could happen when all tracks are turned off or have no DB loaded, or when the current audio device reports an error.
It might be that the audio device gets stuck. Have you tried switching to another device and switch back in Audio Settings?

Yeah that’s what I mean. I’ve not had my audio device have any problems before, but I have SynthV open rn, and am waiting for it to do it again so I can test what u suggested. I will update if it works or not.

Note: when I asked other people who use SynthV about it, they just shrugged it off as a thing the program does.

I remember hitting this issue before Tech Preview but it’s been a few months since I last replicated the problem. It was running just fine since then. Anyways, any instruction would be appreciated.

When I tried changing the audio device and setting it back, it worked but the program chugged for a minute or so. Unsure if that was my computer or something to do with the program. Thank you for this fix!

Edit: it seems to happen when it’s been left alone for a while, or the laptop is shut then opened. It’s no wonder I’ve gotten it a lot, as I have a tendency to leave tabs open.