Synthesizer V Editor does not save any change or new tracks!

lang:en

#1

I have been successfully using Sythesizer V Editor in the past. Now, after a few months of inactivity, I created a new Project and a few new tracks into it. After “Saving” the project and re-opening it, I see that nothing is saved inside the Project. I updated the editor to the new version (Mac Build 016) just in case, but it did not solve the problem. I can’t figure out what I may be doing wrong. As far as I can tell, I am not doing anything different from before. All licenses for voices are still current. The software says the Editor license is also valid. Any suggestion?


#2

This sounds likely to be a problem with application privilege (in simple English: the operation system does not grant the Editor rights to save files). I think the problem has been fixed in Build 017.


#3

Thanks for the reply but I think that it is unlikely that the cause is a lack of the application privilege. 1) The Editor (maybe Build 015) worked normally before (saved the Project, Tracks and any changes made to tracks - such as lyrics, loudness, etc.). 2) Build 017 has been installed in May which might have caused the problem. 3) Build 017 has been re-installed just in case, but it still does not save Tracks. 3) The project file .s5p itself is created by the Editor.

However, if it is the application privilege, how do I change it? I used MacOS 10.13.6 and Synthesizer Editor Build 017.