The UI displays incorrectly on a high dpi scaling screen in OpenGL-rendering mode

todo:b015
bug:unconfirmed

#1

Steps:

  1. Set scaling to 150% (or higher) in OS settings. (May need to logout and re-login to apply new settings)
  2. Open Synthesizer V Editor.
  3. Select Settings -> Preferences to show the Preferences dialog.
  4. Check the checkbox “Enable OpenGL-based GUI rendering” on.

Expected result:
The controls in the application stay the same while rendering in OpenGL.

Actual result:
The size of the controls in the window is enlarged so that the menu is inaccessible.

Environment:

  1. OS ver: Windows 10 1809 (build 17763.195)
  2. SW ver: build 103

Additional information:

  1. This issue does not occur when the OS scaling is normal (i.e. 100%)
  2. This issue also occurs when both the “Compact mode (for low-DPI devices)” and “Enable OpenGL-based GUI rendering” are checked (even the OS scaling is 100%).

Attachemnt:
Normal UI:


Incorrect UI:


#3

Related issue:

Will look into this later. Any attempt at replicating this issue is appreciated!


#4

Verified in build 014, this issue still occurs.
Will check it in the next build.

Workaround: Set “Global UI Scaling” as the same value as in OS settings. (i.e. if the scale is 150% in OS display setting, then set the value of “Global UI Scaling” to 1.5)


#5

I don’t think Windows compatibility scaling is meant to work with graphically accelerated softwares though. Why don’t you just disable the OS scaling and use the internal one instead?


#6

Why don’t you just disable the OS scaling and use the internal one instead?

I think it because other app may need OS global scaling to make then bigger on hi-def tablet screen.


#7

Currently many laptops are using hi-res screens. And more and more 4K monitors are used in desktop computers. Setting OS scaling back to 100% will make the size of the text on the screen extreamly small.
My suggestion is to use the OS dpi scaling value as the value of the “Global UI Scaling” and hide/remove this option.
I think Font Scaling is enuogh in most cases. Let the advanced users adjust the DPI scaling in the OS settings themselves…


#8

Oh is that OS scaling setting global?
(I don’t have a Windows tablet at hand to test this.)


#9

Yes. For example the recommended/default scale of my 27" monitor will be 150% since the res is too high.


You can also try to adjust the value in any monitor to test it.


#10

Understood. Will try to figure this out. Thanks!