Synthesizer V ARA Plugin Crashes in Logic Pro X 10.5.1 (MacOS Catalina)

Hi everyone,

I just bought Synthesizer V Studio Pro today, and while the standalone app works fine, I’m one more of the many users (as it seems) for whom Logic Pro X crashes instantly once they try to load the ARA plugin.

  • I’m running Logic Pro X version 10.5.1 on MacOS Catalina (10.15.) on an iMac (27”, 2017, Intel, 64 GB RAM).
  • The error is independent of whether I load the Synth V plugin on an audio track or software-instrument track.
  • I’ve already tried the workaround of removing the scripts in the Application Support folder (by moving them to a backup folder on the desktop, rather than deleting them outright).
  • Using Rosetta, which some users with newer computers seem to have to do, does not apply to me, since my iMac is old enough not to have one of these new Apple chips.
  • One post from 2022 said the demo version would be installed along with the Pro version, and that the demo version must therefore be deleted from the Components folder in order for the plugin to run. In my case, I can neither find a demo version anywhere, nor a Components folder to delete it from.
  • Interesting side note, perhaps: Upon installing Synth V and the “Mai” voice, Logic did not need to scan for Audio Units upon launch, as it usually does. Instead, Synth V ARA immediately showed up in my plugin list. So far, so good — the problem is, I can’t insert it on a channel strip without Logic Pro X immediately closing.

Given how many Apple users seem to be having this issue, is there any progress being made?

Kind regards,
Strato Incendus

Dunno with Catalina… But the only way to run SynthesizerV in Logic W/out crash, ARA bridge etc. , is to run Logic in “Rosetta mode” at the moment (for me and for the most, I guess).

Thanks for your reply! But as far as I can tell, Rosetta mode doesn’t even exist yet on Catalina? Or rather, does not exist on iMacs from 2017? Because as I understand it, Rosetta mode is only required on newer Macs to use software designed for older Intel Macs. My iMac from 2017 has an IntelCore i5 processor.

In fact, Spotlight doesn’t even suggest to me that I could install Rosetta in the first place.

What is ARA bridge? Might that be a viable alternative for me?

1 Like

Ok. Had even no clue for Catalina. ARA bridge is the only way SynthesizerV runs on Logic nowadays. It’s not fully ARA like in other fully supported DAWs. It only permits tempo adjustment inside the DAW that will submitted to the SynthesizerV plugin, not all the other features.

1 Like

yep i just bought synth V and the moment i add the ARA as an effect in FL Studio it crashes instantly, I’ve never seen anything like this lol. The regular synth V studio works as an instrument but why is the ARA version crashing???

1 Like

FL Studio does not support any version of the ARA protocol.

Last I heard they were hoping to add it as one of the next minor updates (so 21.3 or 21.4), but no concrete information has been given beyond that.

Thanks for your replies! :slight_smile: I got the regular plugin to work inside Logic Pro X — as far as I recall, the first time I tried, the regular plugin made Logic crash, too. But perhaps I had merely put it in the wrong spot? Namely, as an insert effect, rather than a VST instrument.

Anyway, I tried the same thing again — inserting the regular Synth plugin as an instrument — and by now, that part works. However, as the others have stated, the ARA plugin continues to crash immediately upon inserting it into a channel strip.

This leads to some annoyances, like having to manually synchronise the tempo within the Synth plugin with the host project again (luckily, there’s a button for this!). As far as I’ve understood it, these are the kind of nuisances that the ARA plugin is trying to counteract, by creating a tighter connection between the Synthesizer V plugin and the host DAW?

I had sent a mail to support, too — however, I’m not quite sure they understood the issue, since they only asked me to uninstall the entire software and reinstall it with the firewall turned off. But as we’ve established, the standalone software always ran smoothly, and now, the VST plugin within Logic does, too. It’s only the ARA plugin specifically that keeps failing.