Synthesizer V VSTi not saving anything

I purchased SV a week ago, so presumably I have the latest version. I created some vocal lines with 4 tracks in the editor inside of Cubase.

I saved the Cubase file. Reloading it, all the SV tracks were gone. Nothing saved at all. Of my four tracks, only the first one appears, but empty.

Is this a known issue? Used error? I would expect that all data in a vsti is saved with the song? Please tell me that this is our can be fixed?

Thanks,
CS

I made a few more experiments.

The sw versions I have are:
Synthesizer V Studio Plugin 1.0.6
Synthesizer V Engine 2.0.8
© 2020 Dreamtonics Co., Ltd.

I am running Cubase 11

Apparentlyl, nothing in the PlugIn editor gets saved with the Cubase CPR file. That feels like a pretty monumental bug. Is there a fix available? Or at least anticipated? A work-around?

Found an update option to 1.1.1 in the license panel.

1.1.1 seems to save, but only after I save a separate data file.

I really love SV as a tool, but that behavior I feel is less than ideal for a VSTi plugin. Other plugins with built-in TL editors, such as Melodyne or Vocaloid (the plugin, not the built-in editor) save just fine with VSTi.

I believe that in the VST SDK it is expected for a plugin to fully serialize and deserialize its state to the host. This is described here: https://steinbergmedia.github.io/vst3_doc/vstinterfaces/index.html#Persistence

It should not be necessary to first save the state. Is there any chance for that to get fixed?

Thanks so much! I can’t wait for more english-language content for SV2, I know I will buy it immediately - but please fix the VSTi saving.

Even better would be support for ARA2: That would make it possible to support clips in the timeline instead of just linear tracks. For my workflow that would be simply amazing. ARA is supported by most common plugin hosts as well as Melodyne and Vocalign - plugins that do similar things to Synthesizer V in terms of editor and track management. More info here: https://www.celemony.com/en/service1/about-celemony/technologies

2 Likes

And one last comment: Even with the 1.1.1 version of the plugin, it seems saving is hit and miss - I just tried it again, and it would not reload. Please please please fix that.

I agree - saving the SynthV project within the DAW project would be ideal. It’s one thing that keeps me from using SynthV as a VST. But to be honest, it’s not he main thing. I just don’t like the behavior of the plugin compared to the standalone.

You are saving your .svp project file from SynthV to a file on your computer, right? You then need to lead that file.

Does ARA support MIDI? I would love to write my MIDI in reaper, and have Synth V recognize it - but I don’t think that’s an ARA thing.

I ran into this same issue this weekend. Apparently, it’s necessary to manually save a SVP file from within the VSTi plugin. Otherwise, all progress is lost when the DAW is closed. As others have already pointed out, the expected behavior would be for the plugin to serialize the SVP directly into the DAW’s project file.