Bug: Using Neural Network Performance Tuner in VSTi permanently breaks voice rendering in Reaper

I foolishly decided to use the benchmark tool in the Synthesizer V Studio Pro VSTi plugin in Reaper, and when I hit Apply and restart Live Rendering System, it forces Reaper into a Not Responding mode. I waited over 30 minutes and the program never responded, so I terminated the program.

Now, no Synthesizer V plugin instances in Reaper produce voice sound, I have created brand new projects and added a new plugin to test this. The keyboard in the piano roll still produces sound, so it’s the voice engine that’s broken.

The regular desktop version still works fine, it’s just the VSTi that is having voice rendering issues. Is there anyway I can reset the plugin’s default settings?

I did some digging into the VST3 folders looking for settings files and a thought occurred to me. If the vst3 file stores its settings internally or in the same folder (in Program Files, a protected folder that requires admin privileges to modify), I might need to run Reaper temporarily in admin mode to properly apply the settings.

So I ran Reaper as an admin, did the performance tuning and pressing the apply button succeeded instantly. I have sound in the VSTi plugin once again!

If anyone else runs into this problem, I hope it helps them resolve it.

1 Like

Just a quick update.

The synthesis engine stopped working for me after I closed Reaper. The admin trick no longer worked (and it was causing crashing again even after several system reboots), so I deactivated all Synthesizer V licenses (voice banks and studio pro), then uninstalled studio pro and reinstalled it fresh. I’ve tested in Reaper, closed it, and reopened it, and it’s still working.

So for now, I think it’s probably a good idea to stay away from modifying the Live Rendering System in the VSTi.