Bug with tempo editing?

(I’m using SynthV Studio Basic 1.5.0)
So I was trying to edit my new project’s tempo (which was 120 BPM by default) to 160 BPM. I was doing what you were supposed to do to edit the beginning tempo (right clicking the very first bar of the track and using “set tempo here”) But even after inputting the new BPM the tempo was still 120 BPM. What’s weird is that you can edit the tempo on any other part of the track just fine! Is anyone else experiencing this bug? How do you correct the bug?

Is the existing 120 BPM marker that comes default with a new project still there? It’s easier to edit that one instead (by double clicking) since you’d have to remove it manually after making a new marker before it; any marker at the very beginning would be immediately overwritten by it, since tempo markers are chronological.

Screen Shot 2022-01-25 at 2.54.09 PM

1 Like

Yes, the 120 BPM marker is still there. The problem is editing the marker. Even if I place a tempo marker on the next bar, I cant remove the 120 BPM marker (and it’s not like I can even edit the marker due to the bug I just described)

@applepai I still need your help. It’s been 2 days and even after what you told me, I havent been able to fix the issue with the tempo. Are you NOT supposed to right click the very first bar to change to tempo? If so, what are you supposed to do?

Hi! I’m not actually a moderator or a developer or anything, sorry.
I believe the intention is to right click and edit to the default 120BPM tempo, as it’s the default marker that defines the starting tempo for the project and just happens to be a bit offset to be easier to find; I don’t think this is actually a bug. You can still place markers immediately after it to have the tempo modulate, but whatever that default marker is set to is what will define the tempo for the very beginning of the piano roll.

This may differ between operating systems. Personally I have to double-left-click rather than right click.


@applepai do you not get the problem? You’re right that the intention is the right click the very first bar and change the tempo. The PROBLEM is that whenever I attempt to edit the tempo from the very first bar of the page, it just… doesn’t change. It just stays 120 BPM, 4/4, whatever. This is a huge problem because even that one bar that’s 120 BPM can desync the vocals from the entire song.

The 120 controls the first bar.

@applepai Okay, you clearly do not get the problem. I had high hopes when I got a response from you. The problem is that due to this potentional bug I found, you CANT change the 120 BPM marker at the very beginning of the song. This is a problem because it will desync the vocals from the song if the song is not 120 BPM.

Again, I’m just another user on the forum. If this is a legitimate bug, I can’t help you, but sometimes things are just a case of features not being known; I had this issue initially as well, because I didn’t know better. Have you tried Claire’s method above of double clicking the default 120 to edit it? It IS fully editable. If it’s a case of doing so but the dialogue isn’t popping up, restarting SynthV/your machine can potentially help, or clearing SynthV’s cache. If it still doesn’t, then it likely is a software error.

Screen Shot 2022-01-28 at 1.25.30 PM

Screen Shot 2022-01-28 at 1.25.36 PM

We’ve both just told you what works for us, there’s really no need to be rude. Part of confirming, troubleshooting, and fixing a bug is determining whether it affects all users or only a certain subset.

In this case, applepai is clearly able to change the BPM from the start of the song by right clicking, and I have been able to do so by double-left-clicking.


If you really can’t change the first measure’s bpm, a simple workaround would be to set your bpm starting at the second measure and truncate the first measure in your DAW. Then you would have no desync issues.

1 Like

@claire so I tried something else. I suspected that I might just be clicking in the wrong location, so then I tried clicking directly above the tempo marker. This happened.
Screenshot (1275)
It still didnt fix the issue, it just put a new BPM marker right next to it?
Also, truncate the first measure in your DAW? I feel like people would notice that you messed with the tempo like that.

Try clicking closer to the “1” indicating the start of the first measure.

Trimming samples is an extremely common thing to do in music production. It’s not “messing with the tempo” to remove extra silence from the start of a render.

@ Deadly_Espresso uses Studio Basic 1.5.0

I have older Studio Basic 1.3.0 on Windows and I can confirm, that you are not supposed to rightclick in the 1st quarter of the 1st measure and use “Set tempo here” - it displays dialog “Create a new tempo marker” and creates nothing.
Probably bcs there already is the default marker in the 1st q. 1st measure, which cannot be deleted.

But editing this default marker by double-left-clicking on the number 120 brings dialog “Edit tempo marker” as in @applepai 's image and I can change and save the new value.

It seems that you can set markers every quarter (not only measure), but only one per quarter.
And the 1st one in the track can only be edited, not deleted nor replaced.

I hope it will help somehow.


OK im back with more information
Im questioning if this tempo “bug” was just an odd modification to the tempo system because the tempo system had worked just fine when I was working with an older version of SynthV.
I also do have video footage of the tempo issue in action: i found a bug (SynthV basic, 1.5.0) - YouTube

Hey I tried the double left click and you’re correct! Thank you!