Basic Synthesizer V Functions


Warm greetings to all. I’m brand new to this. I’m using a Mac computer with Synthesizer V Studio. I’m having trouble trouble deleting tracks. The online manual instructs us to go to the “Projects” menu, and when you pull it down, all that is needed is to hit the “Delete Track” function. It looks like the on-line manual was written on either a windows or Linux-based computer.

The problem with the Mac, is that there IS no “Delete Track” function on the “Projects” pull-down menu, and after searching all other pull-down menus, pressing all sorts of buttons on the GUI,and exploring the application, I can find no “Delete Track” function. The closest thing is a “Delete Selection” function in the “Edit” pull down menu. This apparently only deletes selected data without effecting the track, itself. Every combination of keystrokes and all permutations of them that I’ve tried fail to delete tracks.I even let my cats walk on the keyboard (they have found inventive ways to do things I never knew the computer could do, and it’s got them stumped, as well. ). If there is a way to do this on the Mac, I’d be most gratefult whoever can solve that mystery for me. Anybody who can help me out on this would be saving civilization, as we’ve mostly come to know and love it. Thanks in advance!

The manual is for the legacy version of the software and does not apply to SynthV Studio. Many things are the same, but a lot of things have also changed in the years since that old version. Notice how the screenshots in the manual are not the same application as the one you’re using.

You can delete a track by right clicking on it and selecting “Delete Track”. Most users will have a regular mouse they can use with their Mac but if you’re using one of their single-button mice or a trackpad, you can use Control + click instead.


This is the official tutorial series for SynthV Studio:

1 Like

Thanks! I already tried that, and still no delte track option comes up. Let me try it again, just in case I somehow messed up when I first tried it. I’ll let you know how it worked. Thank you so much for your response! Take care…

I tried it again using the control + click…no joy. Also, When I opened the project it had deleted all but two tracks of a multitrack piece I’m working on. Now…I’ve got something new to try and figure out. Thanks for your help, Claire…maybe someday I’ll know enough to be able to repay your kindness. Thanks!