OpenGL bug on macOS Monterey

After I activated “use OpenGL for UI” the whole program started to act strange and there is this red backround. I can’t switch it back to the normal and I can’t load any of the voices. Everything seems to be unusable. I tried to switch "useOpenGL=“0” as adviced, but it still doesn’t work. I’m using macOS Monterey.

If you’ve already tried the steps here: Screen Scaling and OpenGL Issue

Then you should consider contacting Dreamtonics support ([email protected]).

Also ensure you are installing the latest version (1.8.0), since this is likely one of the first things Dreamtonics will suggest to troubleshoot.

I tried that, but it didn’t solve the problem. I have the newest version. I guess I have to contact Dreamtonics then

As @claire states, ensure you’re running the latest version, first

Also, if you are using an M1 Mac then you could try running it in Rosetta mode to see if that makes any difference (find “Synthesizer V Studio” in your Applications folder → right-click it → get info → check the ‘Open Using Rosetta’ box).

Unfortunately I don’t think Dreamtonics support is always there when you need it (unless things have changed since I last had issues). I’d wait for their response first, but if you get stuck there may be some kind of answer by repeating some/all of what I did in one of my earlier posts. I am wondering if your XML is updating properly - if not that may explain why changing "useOpenGL=“0” is not working.

1 Like

There is mention of fixes for OpenGL in the patch notes for the current public beta (1.8.1b1). You may want to try installing this version, though keep in mind it is a pre-release and may introduce new problems. If that is a concern you may want to wait until the full release of 1.8.1.

Beta versions must be installed manually (see the topic below) and cannot be installed with the normal in-application update process.

1 Like