Synthesizer V Studio Pro Unable to Update from 1.4.0 to 1.8.0 on Apple Silicon

The product was purchased from Medium 5 in Nov 2021, using the link provided back then for downloading:*******.pkg

Processor: Apple M1 Pro
OS: Ventura 13.2

Steps to reproduce the error:

  1. Install with the installer obtained from the above link.
  2. Activate the editor.
  3. Go to Lisence and Updates → Select Synthesizer V Studio → Check for Update → shows update available → Click update
  4. Starts updating. Progress goes from 0% → 100%
  5. After progress reaches 100%, SynthV window moves off screen while not quitting the process.
  6. Going back to SynthV, still shows version is 1.4.0, and that Synthesizer V Studio is available for update.

Tried to restart the machine, reinstall SynthV, and reactivate the product. No luck so far.
Any help is appreciated.

You can try downloading the latest installer from Dreamtonics: Dreamtonics Download

1 Like

Thanks a lot, been looking for the download page.

Worked for me. Thank you for your help.

1 Like