Midi Recording Additions

(Re)recording a specific part is very clumsy as is, please consider the following …

  1. START + END RECORDING
    Add a - punch in (start) - punch out (end) - recording option
    Something like the Left-Right loop locators

  2. PLAYBACK TONE
    While recording add a tone as substitute of the voice
    So you can hear what is sung while you record
    So a tone for the voice and a tone for the recording

Thank you for your ear!

3 Likes

YES!

One year later - AFAIK it’s still not possible to set up punch in/out points for recording small segments - am I missing something??

The only way I can use SV (for my purposes) is to play in the notes while syncing with tracks in Logic Pro.
I can try to go in one pass but need to record over parts and fix them by punching in because they don’t all go perfectly - especially when I have my left hand on the MacBook Pro keypad - and one hand on my keyboard controller. Jumping back and forth affects the performance and makes it worse.

Is there a record on/off keyboard shortcut (equivalent to manual punch-in) I can hit on the laptop on the fly while playing in sync? If so - does it record over the previous notes (just like a tape machine)?
That would at least be something - hover one finger over a key - punch in and back out before/after playing the new part. Repeat as many time as it takes :slight_smile:

The default hotkey for recording is the * on the num pad, but you can reassign it to any key from the bottom of the Settings panel.

If you don’t want to overwrite your previous take, you can record to a new track and only copy the notes you want (ie from what would be your punch in/out window) back to the original track.

2 Likes

BlockquoteThe default hotkey for recording is the * on the num pad, but you can reassign it to any key from the bottom of the Settings panel.

Logic doesn’t like the * key being pressed - it jumps the program into a different screen configuration.
I’ve been trying different single hotkey assignments and haven’t found one yet that’s not co-opted by Logic.

Even with ARABeta one has to be in the Logic window to start play - then click out of Logic, into the SV plug in window before attempting record enable. (more clicks to get that working - while Logic is playing live). I’m just learning but so far it’s very clumsy and requires slowing the tempo and/or giving lots of lead in time to get things settled after record enable, before playing in the parts. Once I’m done recording I hit spacebar to stop - which won’t stop Logic - it only stops SV. Spacebar is always been stop for all audio programs - but not quite in this case. More clicking first.

Maybe I’m wrong, but AFAIK the SV transport can’t start/stop Logic - this would make things easier.

With the ARA bridge the plugin should be able to control the host playback. Does the application say “ARA Bridge Link” in the upper right corner like is shown in the screenshot?

From the ARA Plugin Guide (“How to set up the ARA Bridge” section):

Synthesizer V Studio ARA Plugin (AU) functions under the ARA Bridge mode on Logic Pro. ARA Bridge offers essential feature extensions over the standard AudioUnit plugin: the ability to control the host’s playback from within the plugin and to synchronize all tempo events at once.

Note that ARA functions are only available when running in Rosetta mode, because Apple has not yet updated Logic Pro to support ARA when running natively on Apple Silicon.

Yes it does - I have tried toggling the ARA Bridge Link button - and also clicking the “Synchronize Tempo with Host” function (which has no active/inactive indicator or checkmark). So far I haven’t seen any Logic control working from the SV transport no matter what I try. (Logic Pro 10.7.9 Rosetta)

Thanks, BTW for the idea of using new tracks in SV (to assemble later) as a substitute for automated punch in… that can work well enough!

EDIT - I’m going over it all and might be missing this part - "To set up the ARA Bridge in Logic Pro, create an audio track and load “Synthesizer V Studio ARA Plugin” as an Audio FX - I’ll have to go look and see if I can figure that one out. If there was an individual plug-in for the ARA Bridge (vs just using the Beta SV) I’ll have to locate it as well.

EDIT 2 - Trying to load this crashes Logic. :frowning: Once I click "stereo - poof - Logic is toast.

Right before Christmas I started getting very, very frequent freezes when using Synth V (beta 2) in Logic (10.8.1 on Intel). I could only work 30 sec to a couple of minutes before Logic completely froze. No crash so no crash log file and so no info on what was happening. Super annoying!
Contacted Dreamtonics support who responded quickly and were very helpful! Gave me all sort of suggestions but nothing helped. Finally they began to suspect the Synth V scripts folder and asked me to remove ALL scrips. To my surprise that solved the problem instantly. Haven’t experienced a single freeze since removing all the scripts from the scripts folder! What a relief!!
Your problem may of course be due to something else but you can easily try to move ALL the scripts to your desktop. You will find the scripts folder is here:
/Library/Application Support/Dreamtonics/Synthesizer V Studio/scripts

1 Like

I had heard that embedded JavaScript doesn’t work very nicely when Logic Pro is the host, though I’m not sure if the same applies to Lua.

Hopefully you don’t have to remove all scripts, but if that’s what it takes to get things working I suppose it is what it is, at least until a fix can come in from Dreamtonics and/or Apple.

1 Like

I suspect that many (most?) scrips are fine but at the moment I cannot do any tests as I have a deadline for a music course coming up in just a few days!
I got the impression that Dreamtonics will try to address this issue although they did not explicitly say so!
At the moment I am just very, very happy that Synth V and Logic with ARA works really well!

1 Like

If a script includes switch(){}, it doesn’t work in Logic.
Scripts not include switch(){} are available in Logic.

This all probably should have been in another thread but FWIW I tried removing the scripts folder, restarting - but it still crashed when I tried to load the ARA FX plug-in. It’s a mostly brand new MacBook Pro with hardly anything installed on it, so not sure what the cause could be - but I’m working around it - just lacking some functionality apparently.

Have you tried to contact Dreamtonics support? They responded quickly and were very helpful!

1 Like

I found the error - my fault - but it would help immensely if the documentation stated that adding the ARA FX plug-in must be done first before anything else.

It was a case of my reading and doing everything it said - versus - doing everything it says - in the exact order it says, too. I was able to figure that out by starting a new project and then going over the process again, step by step.

My issue was I had done a SV vocal track first - then tried to apply the ARA FX plug-in. It didn’t like it!

Maybe this help help others who run into this…