Parameters and note copy

I recently copied the midi notes with the words attached ( for a chorus ) which I wanted to be approx the same . When I did this the parameter settings did not move with the notes (pitch, soft, clear etc. ).

I found i could do this by selecting move the “note parameters” Why would you have this as a select, moving the notes that you have already adjusted along with the parameters should be the default, it is easier to change these settings after you have moved if you didnt want them to be exactly the same , rather than not move them in the first place.

I also accidently moved “ALL parameters” after only selecting the chorus, which totally destroyed the rest of the song that I had spent hours working on. Of course I didnt notice until after I had made a save. so had to start over, dam it!!!

Please make parameters move with the selected nots and lyrics as default.


To select the parameter points for the selected notes you can right click and choose the “Select Parameters for Notes” option (default hotkey ctrl+alt+A).

In the case of two phrases which are identical, it’s generally a good idea to group the notes (with their parameters) and then copy the group as a whole.


Hi Claire, thanks as always for the tips. I will do this right click… However my point was really that the default when copying should be with the parameters, and the option to copy without parameters should be the selected as ‘not the normal copy’

Also the point is that to adjust or start again adjusting the parameters, from what has been copied is probably less usual than copying and starting to adjust parameters from scratch (after adjusting the first time ).

I will also read up on how to copy the group with parameters, probably a better way to do it for a chorus.
but I like to copy a chorus with existing parameters and then make very slight variations. I realize I could do this by un-grouping after the copy.