The window becomes black in OpenGL mode when 3D acceleration is disabled

Well, of course I know it’s not actually a “defect”. It’s silly to disable 3D acceleration while using OpenGL…

This is how the story goes:
I just want to render my project on my server computer. So I connect to it from my PC by Microsoft Remote Desktop Connection.
OpenGL mode has better performance, you know, so I’m used to enable it. But I forgot that 3D acceleration is disabled in MS Remote Desktop… That’s why I got a black window… :joy:

So is it possible to give user an error dialog here when user wants to enable this option while the 3D acceleration is disabled? Or always disable the OpenGL mode in this situation?