Copy paste not working for me (Logic Plug In)

Something odd going on but can’t figure it out. I’m not a total dummy - but theoretically I should be able to drag select a range of notes and copy (tried keyboard shortcut and menu command) - and then paste them to another track - or region/measure.

The very first time (only) I tried it asked where do I want to paste (at the playhead or other options - I selected in the same widow area I believe - my goal was to copy paste at the same location from one track to another). I have never seen this dialog again - no matter how many times I try - and BTW - the paste at that time resulted in nothing. ALL my copy and paste tries are doing nothing.

I tried making the region into a group but that didn’t work.
I tried the right-click menu - but that didn’t help.
I tried quitting and restarting - didn’t help.

After a copy - the menu indicates there is a paste in the clipboard queued up - but pasting = nothing.

I know I’m going to feel dumb when I finally “get it” - but what am I missing? This is really basic and mind boggling at the same time.

EDIT - I tried copy/paste one note and it seemed to work. Something to do with selecting a region is the issue.

Work around - not solved
Command C - Command V simply wasn’t working but I found a work around.
Create a group. (Copy paste still won’t work)
DRAG that group to the other track. This MOVES it over. Key commands or menu commands don’t do it. Sill no copy/paste working for me.

Maybe I can duplicate a track and then move parts instead.

UPDATE - tested a bit using the program (not the plug-in) and it works fine with key commands. Maybe just something buggy with the Beta.

I use the latest beta in Logic and have recently copied and pasted a lot. I select notes, right-click and select Copy. Then place the playhead in the intended position and right-click and Paste. Have not had any problems! But CMD-C and CMD-V does not work for me.

1 Like

Thanks for the reply. I think I solved it - starting a new project in Logic - #1 fixing the ARA issue I was having (by adding the ARA FX first before anything else in a new project)

  • And then only using the right-click UI to copy/paste. Keyboard commands are still broken. Knowing this was helpful to limit my experimentation to known things that do work!

Are you clicking on the Piano Roll panel before pressing the paste keys? If you’ve just switched tracks, the track list in the Arrangement panel will still have focus.

Thanks - I solved it. Mostly I was unsuccessful because the key commands don’t work - but the contextual menu method does. It might have also been adding the extra click into the piano roll area on the other track too - vs just changing to the track only.