SynthV crashes Logic Pro X As soon as i open it

Like the title says, as soon as i open Synth V on a instrument track, Logic crashes straight away.

Help please?

Which macOS, which Logic version, which SynthV?

I run macOS Sonoma 14.1 and Ventura 13.6.5 and on both machines Logic 10.8.1 and Synth V Studio 1.10.1 and don’t have such issues.

PS: In case you run macOS 14.4 be aware, that it is buggy as hell.

I definitely do not agree! I’m on 14.4 and SynthV works acceptably like on 14.3
Not great but it works!
But use an Intel iMac and maybe that makes a big difference?

It seems so, yes. Fact is, that 14.4 has a lot of issues, e.g. with Java … but in this case not on Intel machines.

Then there are printer issues, especially with HP, but I don’t know, if the CPU plays a role. Furthermore issues with iLok, which I didn’t inspect closer, because I always hated iLok and don’t use it. And finally … not to forget USB issues.

Google for “issues with macOS 14.4” to find out more.

1 Like

Thanks everyone. I got it working.

The fix was opening it up first as the standalone application (outside of logic), do all the updates, then reopen logic and then SynthV.

1 Like

I believe that most if not all 14.4 issues seem to affect Apple Silicon only or at least mostly. And I have no issues with iLok USB despite using it for around 50 licenses from various developers!

Possible … at least Intel Macs aren’t affected by the Java issues in 14.4

1 Like

Also it might be affecting more M2 and M3 users than M1 users. My ILok licences (those that I’ve so far tried) seem to work OK. But his must be the worst Apple updates all-around that I’ve ever experienced from Apple. Just spent 40 minutes re-creating my Home as it had completely disappeared from my iPhone with the 17.4.1 update in iOS :frowning:

Why?

It’s the first time a minor update caused major issues. And for my taste it takes already pretty long to fix that mess.

Comparison to a different case: I reported a login bug in the Xbox app on Windows 11 ARM (final version) through the Insider Program and it only took 2 days until a fix was released.