Import midi from cubase or melodyne

Hi. I’m brand new to Synth V pro. I’ve read the unofficial manual and looked at most of the videos but I’m running into an issue. It’s probably simple but was hoping to get some help. I have a project in Cubase. It’s in 3/4 at 133 bpm. I export the piano audio and the vocal I want to copy in V Synth as a midi and audio file (all audio is wav). I create a new Synth V project and place the time signature and temp at the start. I create instrument tracks and drag in the audio files. The audio files all sync. Then I create a “New Track” and “import as track” the midi file that matches the vocal audio track. I’ve tried both selecting letting Synth V “clean it up” and doing in manually.

In each case, the midi track does not even remotely match the audio. It is considerably longer. Am I missing something? If the midi track is exported (either from Cubase or Melodyne) from the audio file, and the tempo and time signature is the same, why doesn’t the midi match the audio in Synth V? I really like this program but I’d prefer to not have to pencil in all of the notes. Thanks. I appreciate the help.

1 Like

It’s hard to say exactly what’s going on from that description. The first thing to check is whether the issue is with the files, or with importing to them to SynthV.

You could try making a fresh Cubase project and importing both files to see if they align properly in that context. This would help verify that the files are as-expected and narrow down potential causes.

The thing is that those files are also in melodyne and aligned there. So, technically, is what I’m doing the correct approach? If so, I can try some other things.

The process you mentioned doesn’t raise any red flags, no.

The reason I suggested reimporting to a fresh DAW project is because even if things are originally aligned in the DAW or Melodyne, if something odd is happening during the export process it might not be immediately evident whether the contents of the MIDI file are as-expected.

And I guess a follow-up question – are the notes in the MIDI aligned correctly with the measure markers? ie is the note at measure 10 the note that you’d expect to be there, or are they offset in some way?

I created a new project with the same tempo and time sig. Verified the same sample rate with the audio. Again, in Cubase, I exported one of the audio files to midi. The midi notes align with the audio in Cubase. I import the audio files and then the midi into Synth v. Again, they are way off. My first question is aligning the beginning of each file. In Cubase, the audio instrument file begins at measure 2. The downbeat for the vocal (midi and audio) begins at measure 30 (in Cubase). After importing into SV, the audio instrument track is pasted at measure 1 (actually, it’s off because the audio track has a bit of free time before the waveform starts at 2). I can correct the location of the audio to match the bars but there doesn’t seem to be a way to move the midi notes around. You can’t select the entire midi track in the arranger to move it, and you can’t zoom the entire track in the piano roll to select and move the midi. This would be so much easier if I could just open SV in Cubase and drag a midi file into it and have it follow the project.

The hotkey to select all notes is ctrl+A. You should be able to drag everything once it’s selected.

It looks like Cubase only exports a blank lead-in if you explicitly place the left locator at the start of the timeline: Empty MIDI Regions at Start and Ending get cut away on Export - Cubase - Steinberg Forums and Not sure if this is exactly what caused your situation, but it could be the reason that the leading silence was “trimmed” from the start of the file.

Well, I’ll have to get back to this tomorrow, but even the audio seems wrong. Same tempo and time sig but in Cubase the audio piano goes from bar 2 to bar 180 (4 minutes). In SV it goes from bar 1 to bar 161. Is there any way to check the time in SV. It only seems to show bars but not seconds. That would tell me if the length of the audio is being altered.

Enable the Status Bar via the Settings panel, then mouse over a point on the time axis (where the measure indicators are). The current position in minutes and seconds will be shown at the bottom left corner.

It’s worth noting that 161 bars at 120 bpm is roughly the same duration as 180 bars at 133 bpm, so that’s likely the issue.

I rendered the track and it’s the same length. Went back and checked and see that the tempo changed back to 120! How do I prevent the tempo from changing. (Sorry for all the questions but so far it’s not the most user friendly app.)

Hmm… It shouldn’t have changed on its own, though if you created a new project at any point in your attempts it would have started back at the default 120. Hard to say for certain.

OK. I’ll try again tomorrow. If I can work out a workflow I’d love this app. I really need it. Again, if I could use it in Cubase and have it follow the project (create an instrument track in Cubase that I could send to SV) that would be ideal. thanks so much Claire.

If you have Synth V Pro you should have the Synth V Vsti which you can load as an instrument in Cubase. That’s what i use. Haven’t tried importing midi into the instrument but it should be possible. I just draw all the notes in by hand. You could probably route the midi out of a track to the midi in of the vst and hit record as you can now play midi notes into the vsti via a midi keyboard.

1 Like

Getting a bit closer but it’s still far from intuitive. I’m running SV as a vst in Cubase. After numerous tries, I managed to route the output of a midi track into SV and record it (frustrating that you can’t control transport of Cubase and SV from the same place). What’s really throwing me off is that the transport cursor line in Cubase in no way matches the one in SV. It plays it back in time, but if I want to accurately edit timing and I see the note in Cubase ends at measure 43 it’s measure 33 in SV … with the same tempo and TS. I can’t sing a lick so I’ll find a way to make it work but it’s really buggy.

Duh. Never mind on that last one. I had the measure bar in Cubase set to seconds. No wonder it didn’t match… though it’s still an issue that you can’t move the location bar (whatever it’s called that tells you where the play head currently is) in Cubase and see it move in SV.

It can be a little finicky. When you first start using the vsti it might help to click on Project and then Synchronize Tempo with Host, only have to do it once. If you have tempo changes or timing changes after the initial tempo and measure you have to add them manually to the plugin on the bar meter. With that done when you move your transport bar in cubase it should sync up.

Hi James. I too have Cubase but prefer to use Synth V in standalone. To help alignment of MIDI I add a -C2 note at the start of bar 1 (you could add any note). I also drag Audio/MIDI into Synth V rather than import and find that works fine. I use a piano as a vocal guide in Cubase so I export that as MIDI and Audio for alignment and find that works.
Workflow wise I have suggested to Dreamtonics a toolbar (like the right click we have in Cubase that can also be configurable for all DAWs as that would help workflow). Also I have set up Stream Deck (see image) and that speeds up things no end but for sure there are areas where workflow improvements could be made.
That said I think it’s pretty amazing.
SynthV StreamDeck

I use Cakewalk but same process. After converting wav to midi I then always go into midi file and put a dummy note on beat 1:1:0 beat 1 bar 1. then save that before I export midi file then bring into Synth V. Maybe not the same issue you are having but a suggestion.

Yup I have this problem too. Work in hand, not so far advanced as you guys, but if the audio and Midi are not synced properly and the audio (converted from mp3) is not the same length this is a major issue for a 3min song

I use Cubase 12 btw. will report on progress taking hints from above first
Certainly a workflow (like this , not like this Tommy Cooper) is needed.

I really appreciate everyone’s help with this. I’m using it primarily as a vst and it’s getting much closer. As I’m finishing the current project, I’m noticing that the pitch on some of the notes are way off… a couple almost by a semitone. I’ve tried reducing the modulation and retakes with only minimal success. I can fix it after render with Melodyne but I’m certain I’m missing something. I see there’s an auto-retune feature but I can’t seem to get it to work. Any quick suggestions?

I noticed this short C2 note appearing in SV. I think it puts one on a new track somehow. Its not explained in the UUM
But I can see its a sure way to get a sync point for both Cubase and SV. Maybe put one at the end also ?

Bit like a clapper board for films?