Running SynthV (build 015) on Linux Solved (partially)

lang:en

#1

Hi I’m sorry for asking, but I have a problem with running SynthV (especially the newest build) on Linux Mint. The problem seems to be that “SynthV” get interpreted as an “application/xsharedlib”.
(The make the file executable is checked in the permissions tab)

I’m new to Linux and in the previous build (014) I found out that adding the .sh after the name on the “synthesizer-v-editor” lets you run it (double clicking on it). However this method does not work with the newest build.
I’m really sorry, but could anyone provide any help, because what I find in other Linux forums still confuses me a bit. Thank you


#2

Hi fellow Linux user! I will try to help you, please follow these steps:

  1. Open your terminal
  2. Type the following command in your terminal (without quotes): “cd /home/your_username/synthv-editor”
  3. Change “/home/your_username/synthv-editor” according to your path where you saved the SynthV
  4. And finally type in your terminal(without quotes): “./synthesizer-v-editor”

Hopefully it will launch :slight_smile:
If you have changed it to something else like “synthesizer-v-editor.sh”, there is no need to do that because this is an executable file, and .sh is shell script.


#3

Hi thank you for the help.
It does not run, but now it I am getting the same error “Kozet” was having

./synthesizer-v-editor: /usr/lib/x86_64-linux-gnu/libcurl.so.4: version `CURL_OPENSSL_3’ not found (required by ./synthesizer-v-editor)

This is the output of the terminal, I tried running the command that “khuasw” suggested, but that does not seem to work either.

ERROR: ld.so: object ‘/usr/lib/libcurl.so.3’ from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.

This the output of the terminal after that command. I should really learn this new OS especially the terminal. Anyways thank you for the help I’ll try to solve the issue


#4

I had the exact same problem you are having right now (it’s missing package). I fixed it by installing libcurl-compat package but I am on Manjaro and i don’t know if Linux Mint has the same package. I hope this was usefull information.


#5

that not solve my problem.
my distro is debian buster, there is not libcurl.so.3 exist on my distro.

reference issue


#6

Hello ywaby,

The information you provided is little vague but you probably have missing dependency package problem. Since your distro is debian buster:

  • See available libcurl packages for your current distro
  • Check if any of these packages are installed, if not install them
  • Since there are libcurl4 and libcurl3 try with v.4 first but it’s probably not going to work. then try v.3
  • Also try launching from terminal with LD_PRELOAD, that fixed it for me but I had to install the libcurl-compat package first…

If all fails experiment in virtual machine with debian stretch, it’s always better to use the stable version with non-rolling release distros (because some packages are missing in buster currently) or some other distro.


#7

Conclusion

  • Firstly go to your package manager (or something similar) and install curl v3 (curl v4 does not work correcly, it should be uninstalled to run “SynthV”

  • Then run these commands

cd /home/your_username/synthv-editor

LD_PRELOAD=/usr/lib/libcurl.so.3 ./synthesizer-v-editor

(note: change the path, accordingly to where you installed synthV)

This should work (worked on Linux mint 19). Thank you for the provided help @marex01


Installing SynthV on Linux?
Running synthV on Debian Linux
#8

The solution suggested is cumbersome. The synthesizer-v-editor itself should be fixed to work both libcurl.so.3 (on old OSs) and libcurl.so.4 (current OS releases), so that it would work out-of-box. This is reasonable, since Synthesizer V download for Linux says Ubuntu is the target OS. It, however, works with neither of current Ubuntu production releases (18.0.4.2 and 18.10). It worked on 18.0.4.1 but that release is no longer available.


#9

We can just remove libcurl4 and install libcurl3 on ubuntu 18.0.4.x

For Ubuntu 18.10, libcurl3 seems to be deprecated. So we have to downlaod the deb package file for libcurl3 (and dependent libs) and install it by dpkg… :disappointed_relieved:

And then it can be launched directly, without setting LD_PRELOAD:


#10

Yes. It would work. Thanks for information that the libcurl3 needs to have its dev package installed. I couldn’t find libcurl3 for Ubuntu 18.10 anymore as you pointed out. So I stopped there. I would also need to install gcc and make, etc., wouldn’t I? The regular “normal installation” doesn’t come with any dev packages or tools.


#11

You could try to search and download the deb packages from https://www.debian.org/distrib/packages.
When you run sudo dpkg -i libcurl3_xxxx.deb It may show that some dependent libs are missing. Just search them on the above url again… :grin:


#12

Not such a good solution, as I need the newer libcurl for other packages.

(I suppose this is where I should use “containers”, after all it’s part of my day job…)